Completed[Chain Parameter Update]
Status
Resolved after 5 minutes
Started
May 25, 2022 at 9:30 AM
Completed
May 25, 2022 at 9:35 AM
Affects
Testnet
- CompletedMay 25, 2022 at 9:35 AM
- UpdateMay 25, 2022 at 9:30 AM
- In progressMay 25, 2022 at 9:30 AM