Completed
Concordium Testnet Reset

Status
Resolved after about 6 hours
Started
June 13, 2022 at 8:00 AM
Completed
June 13, 2022 at 1:44 PM
Affects
Network Dashboard
Testnet
Wallet Backend
  • Completed
    June 13, 2022 at 1:43 PM

    The testnet reset completed succesfully.

    New node software is released in version 4.1.1. Please follow the instructions for migration as provided here.

  • In progress
    June 13, 2022 at 8:01 AM

    Testnet reset is now in progress.

  • Planned
    June 13, 2022 at 8:00 AM

    The testnet will be reset on Monday June 13th. This reset only affects testnet. Mainnet will not be affected.

    Background

    The current testnet has been running for a little bit over a year. During the testing of the Sirius release we have discovered several issues that can best be fixed by resetting the testnet and starting a new one.

    Effects

    The testnet reset will cause all accounts and smart contracts to disappear from the testnet. For developers with accounts and smart contracts on testnet, this will mean that they will need to re-create accounts and re-deploy smart contracts to continue testing. For wallet holders on testnet, they will need to reset their wallets.

    Process and Migration

    The testnet will be deployed in protocol version 3. Shortly after, the new protocol version 4 will take effect, which adds support for delegation and updated smart contracts. For more details on the protocol update, see concordium-update-proposals.

    New node software in version 4.1 will be released for Linux, Windows, and MacOS. Node runners must upgrade their nodes to this version. Old nodes will stop processing new blocks.

    Detailed instructions for migration will be provided closer to the release of the new testnet here.