Protocol Update on Testnet

Completed
Scheduled for November 21, 2022 at 11:05 PM – November 22, 2022 at 11:09 AM

Affects

Testnet
Updates
  • Completed
    November 22, 2022 at 11:09 AM
    Completed
    November 22, 2022 at 11:09 AM

    Protocol 5 is in effect since block `b15a02f9736133188ceb6cd5216bdb9614c046e0774e8e40fd18fc67dcadfea1`.

  • In progress
    November 21, 2022 at 11:05 PM
    In progress
    November 21, 2022 at 11:05 PM

    Maintenance is now in progress

  • Planned
    November 21, 2022 at 11:05 PM
    Planned
    November 21, 2022 at 11:05 PM

    A protocol update to implement smart contract upgradability and performance improvements will take effect on testnet on November 22, 2022.

    New node software compliant with the protocol update is released for Linux, Windows, and MacOS here.

    Node runners must upgrade their nodes before the new protocol takes effect. Old nodes will stop processing new blocks at that point.

    For more details on the protocol update, see concordium-update-proposals.

    The protocol update on testnet is in preparation of a similar protocol update on mainnet in December.