Protocol Update on Testnet

Completed
Scheduled for May 23, 2022 at 10:30 AM – 11:55 AM

Affected

Testnet
Updates
  • Completed
    May 23, 2022 at 11:55 AM
    Completed
    May 23, 2022 at 11:55 AM

    Protocol update has taken effect and protocol 4 is in effect since block 96786a32535daf7da442e7676605877601414450f8bcf468b04ff899bf505db0

  • In progress
    May 23, 2022 at 10:30 AM
    In progress
    May 23, 2022 at 10:30 AM

    Maintenance is now in progress

  • Planned
    May 23, 2022 at 10:30 AM
    Planned
    May 23, 2022 at 10:30 AM

    A protocol update to add support for delegation and updated smart contracts will take effect on testnet on May 23, 2022.

    New node software compliant with the protocol update has already been released for Linux, Windows, and MacOS here. Node runners must upgrade their nodes before the new protocol takes effect. Old nodes will stop processing new blocks at that point.

    For more details on the protocol update, see concordium-update-proposals.

    The protocol update on testnet is in preparation of a similar protocol update on mainnet in June 2022.